Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jul 22, 2026 - 08:00 UTC
Scheduled
Dear Customer,
We would like to inform you about an upcoming minor database maintenance action that we need to take to ensure continued performance, security, and stability. During this maintenance period, we will be implementing important updates and improvements.
Maintenance Schedule:
Date: Wednesday, July 22, 2026 Start Time: 04:00 AM EST (Eastern Standard Time) End Time: 05:00 AM EST (Eastern Standard Time)
What to Expect: We are performing planned maintenance on our Web production database. The window has been scheduled overnight, outside of normal business hours, to minimize impact to customers. We anticipate that the maintenance will last approximately 1 hour. During this time, our software services may be temporarily unavailable.
Impact on Customers: 1. The Web platform may be briefly unavailable during the restart window, which is expected to take under 10 minutes. 2. Other systems that rely on shared data with Web, including Direct Ordering and Voice, may see minor, indirect effects during the window. 3. This is a configuration change, not a software or version upgrade—no functional changes are expected.
We apologize for any inconvenience this maintenance may cause, and we thank you in advance for your understanding and support. Our team will work diligently to ensure a swift and smooth update process.
If you have any questions or concerns, please don't hesitate to contact our support team at support@itsacheckmate.com or call us at +1 855-953-4340.
Thank you for being a part of our most valued customer base. We remain dedicated to continually enhancing our services to meet your evolving needs, and we look forward to serving you with an even better experience after the upgrade.
Best regards, Checkmate Team
Posted Jul 20, 2026 - 21:43 UTC
This scheduled maintenance affected: Direct Ordering (Direct Ordering UI + Customer Sites, Direct Ordering API) and Checkmate Services (Menu Management).