ItsaCheckmate Support Outage
Incident Report for Checkmate
Resolved
We have confirmation regarding the resolution of the email interruption on Zendesk. We are pleased to inform you that our email support functions are now operating smoothly and as per expectations.

Thank you for your patience and understanding during this time.

We apologize for the inconvenience caused.
Posted Apr 11, 2024 - 05:50 UTC
Investigating
We are currently experiencing an interruption in receiving emails on Zendesk. Our team is working with the Zendesk support team to resolve this issue.

In the meantime, if you notice any of your emails going unanswered, please feel free to contact us at our support line at +1 855-953-4340.

We sincerely apologize for the inconvenience caused.
Posted Apr 10, 2024 - 20:15 UTC
This incident affected: Customer Support Desk (Email, Phone, Chat).