Checkmate Portal Interruption

Incident Report for Checkmate

Resolved

We have confirmation from our engineering team regarding the resolution of the interruption in our Checkmate portal. We are pleased to inform you that the Checkmate portal is now functioning smoothly.

If you continue to experience any issues on your end or require assistance with any other matter, please feel free to reach out to our support teams at support@itsacheckmate.com or call us at +1 855 953 4340 for any assistance needed.


Thank you for your patience and understanding during this time.

We apologize for the inconvenience caused.
Posted Apr 04, 2025 - 18:01 UTC

Investigating

We are currently experiencing an intermittent interruption in our Checkmate portal. We are investigating.
Please feel free to reach out to our support teams at support@itsacheckmate.com or call us at +1 855 953 4340 for any assistance needed.
We apologize for the inconvenience caused.
Posted Apr 04, 2025 - 17:32 UTC
This incident affected: Checkmate Services (Menu Management, Insights).