Resolved
We’re pleased to inform you that the earlier disruption to our support services—caused by a global AWS outage impacting our service provider has now been resolved.
Phone Support and Email Support are fully operational again. You may now reach out to us through all standard support channels without delay.
If you continue to experience any issues on your end, or require assistance with any other matter, please feel free to reach out to our support teams at support@itsacheckmate.com or call us at +1 855 953 4340 for any assistance needed.
Thank you for your patience and understanding during this time.
We apologize for the inconvenience caused.
Posted Oct 21, 2025 - 06:30 UTC
Investigating
We are currently experiencing degraded performance with our support services, wherein our support service provider has been impacted by the global AWS outage. We are investigating.
During this period, there may be disruption with our phone support services and delay in receiving and sending emails via support. We kindly ask for your patience and appreciate your continued co-operation.
We apologize for the inconvenience caused.
Posted Oct 20, 2025 - 18:55 UTC
This incident affected: Checkmate Services (Order Processing, Menu Management, Insights), Point of Sale (Toast, SpotOn, Revel, Speedline, North Key, Heartland / MobileBytes, Clover, Maitre'D, Brink, Revention / HungerRush, FoodTec, Square, Focus, Aloha, MicroWorks, CAKE, Upserve, Other POS), and Ordering Platform (Doordash, UberEats, GrubHub, SkipTheDishes, Postmates, Chownow, Slice, Order With Google (Restaurant Direct), Restolabs, Snackpass, BentoBox, Other OPs).